SE&ビジネスパーソンとしてお勉強中なブログ

スポンサーサイト

--/--/-- -- [Edit]

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

PHP5のインストール失敗 [Debian][PHP]

2008/02/17 Sun [Edit]

目標:PHP5のインストール

Debian GNU/Linux 3.1(coLinux)
Apache2.0.63



1.aptitudeでインストール

# aptitude install php5 libapache2-mod-php5 php5-gd php-pear

パッケージリストを読みこんでいます... 完了
依存関係ツリーを作成しています
拡張ステータス情報を読み込んでいます
パッケージステータスの初期化... 完了
タスクの説明を読み込み中... 完了
E: 問題を解決することができません。壊れた変更禁止パッケージがあります。
E: 依存関係を解決できないため、パッケージをインストールできません
E: Unable to resolve some dependencies!
インストールできないパッケージがありました。おそらく、ありえない状況
を要求したか、不安定版ディストリビューションを使用しているなら必要な
パッケージがまだ作成されていないか Incoming から移動されていないと考
えられます。
以下のパッケージには解決できない依存関係があります:
php5-gd: 依存: libc6 (>= 2.3.6-6) しかし 2.3.2.ds1-22sarge6 はインストールされています。
依存: libfreetype6 (>= 2.2) しかし 2.1.7-8 はインストールされています。
依存: libpng12-0 (>= 1.2.13-4) しかしそれはインストールできません
php-pear: 依存: php5-cli しかしそれはインストールできません または
php4-cli しかしそれはインストールできません
libapache2-mod-php5: 依存: libc6 (>= 2.3.6-6) しかし 2.3.2.ds1-22sarge6 はインストールされています。
依存: libdb4.4しかし、これは仮想パッケージです。
依存: libkrb53 (>= 1.4.2) しかしそれはインストールできません
依存: libssl0.9.8 (>= 0.9.8c-1)しかし、これは仮想パッケージです。
依存: libxml2 (>= 2.6.27) しかし 2.6.16-7sarge1 はインストールされています。

なんかエラーが。。
Debian3.1だとaptコマンドでphp5とか入れられないっぽい?

Debianを4にするか、ソースからインストールするか。。
どうすっかなぁ。

Prev
Debian3.1 → 4.0 アップグレード
Top
SE&ビジネスパーソンとしてお勉強中なブログ
Next
DebianでMovableTypeインストール [Debian][Apache2][MovableType4.1]

Comments

 
 
 
 
 
 
 
  非公開コメント
 

Track Backs

TB URL 

Top
SE&ビジネスパーソンとしてお勉強中なブログ

ブログ内検索

カテゴリー

最近の記事

最近のコメント

最近のトラックバック

RSSリンク

Amazon

楽天 人気商品

なかのひと

iKnow

Dictationバッジ

合わせて

あわせて読みたいブログパーツ
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。